Technical Information

Why can't I play some videos on my Mac?

You can now access the All 4 service and play all the video clips on a Mac, PC and with Linux operating systems, but you have to use Flash, so you need to have Adobe Flash 9.0.124 or higher installed. Mac users will need Adobe Flash 10 9.0.115 or higher.

Not found what you are looking for yet?

Try using the search facility, or click on the contact us button below.