Technical Information

Which iOS version should I have to watch All 4 on the iPad, iPhone or iPod Touch?

The All 4 application on the iPad, iPhone or iPod Touch, only works on iOS 8 or above. If you have an older iOS version or are using an older iOS device, such as iPhone 3G or second generation iPod Touch devices, these are unfortunately no longer supported.

You can check which operating system your iPad, iPhone or iPod Touch is currently using by going to Settings>General>About> and scrolling down do Version.

Not found what you are looking for yet?

Try using the search facility, or click on the contact us button below.